Files Are Missing In The Storage. Inconsistent Backup, To Correct Please Run a Full backup (code 1021)

Situation

An image-based, VM, MS SQL Server or MS Exchange backup plan terminates with the following error message:

Files are missing in the storage. Inconsistent backup, to correct please run a Full backup.

Cause

Once a latest version validity check is performed and some files and folders are detected as missing in the target storage destination, a block-level backup would not be able to be performed without errors. Thus, a necessity for a new full backup is indicated by the Backup application.

Solution

A. The common solution to this issue is running the plan in a full backup mode:

  1. Switch to the Backup Plans tab.
  2. Find the plan that produced the error, then click on it in order to expand the available actions.
  3. Click Force Full Backup and let it finish uninterrupted.

B. In case the issue persists immediately or some time after the forced full backup, it could be caused by one the following factors that should be taken into a close consideration:

  • Incorrect lifecycle policy settings that move the most recent full backup or one of the followed incremental block-level backups to another (usually colder) storage class, thus affecting the integrity of the current backup chain.

To correct the above factor, please readjust the lifecycle policies so that they move only the data older than the age of your regular full backup in days.

  • Removal of the most recent full backup or one of the followed incremental block-level backups through the Backup application's "Backup Storage" tab.

Please take into consideration that all incremental backups in between two full backups are part of one integral backup chain that begins with an older full backup and goes until the last incremental block-level backup before the newer full backup. Removal of any part of the chain renders the backup inconsistent and hinges its restorability. Please utilize backup plan's [data retention policy] (https://help.msp360.com/cloudberry-backup/backup/back-up-a-disk-or-virtual-machine-image/step-8-specify-the-retention-policy) to safely purge older data. Otherwise, please exercise discretion.

  • Manual operations with the backup data directly on the backup storage outside of the Backup application's "Backup Storage" tab.

The same, as explained above for the "Backup Storage" tab data removal, applies to any direct manipulations with the data in the backup storage. If any component of the backup chain is removed, renamed or otherwise altered outside of the Backup application, the backup consistency cannot be guaranteed. Same as above, we recommend utilizing backup plan's [data retention policy] (https://help.msp360.com/cloudberry-backup/backup/back-up-a-disk-or-virtual-machine-image/step-8-specify-the-retention-policy).

  • Presence of several machines backing up the image-based data to the same storage while using the same backup prefix (by default taken from the machine name). The data of different machines could end up mixed up, thus affecting its unassisted restorability. Situation could worsen in case the different machines, in such a setup, also use different [data retention policies] (https://help.msp360.com/cloudberry-backup/backup/back-up-a-disk-or-virtual-machine-image/step-8-specify-the-retention-policy), ending up with affecting the backup consistency further by removing wrong parts of the backup data.

To ensure that the above scenario does not happen, please make sure that any machines that share the same storage account for their backup purposes all have unique backup prefixes:

If several machines have the same machine name (for example, "FILESERVER"), this should be checked on-priority as the backup prefix by default inherits name of the machine from its system configuration.

Unique prefixes will ensure that the backups of different machines will be separated from one another, thus preventing the data from mixing up or the retention policy of one machine from affecting the backups of another machine.

https://git.cloudberrylab.com/egor.m/doc-help-kb.git