Immutability Is Not Supported (code 2523)

Situation

A backup plan terminates with the following error: Immutability is not supported. The storage account in this backup plan does not support immutability (code 2523).

Cause

The occurrence of this error means that the storage account does not support the immutability feature.

Solution

In Managed Backup

The easiest way is to create a new bucket with immutability support. If you are provider or administrator with enough privileges, proceed as follows:

  1. Open the Management Console.
  2. In the Storage menu, select Storage Accounts.
  3. Find the required storage account in the list, click the gear icon to the right.
  4. Select View Backup Destinations.
  5. Click Add Destination Bucket.
  6. In the Display Name field, specify the destination name.
  7. Select the Create new bucket option.
  8. Select the require region.
  9. Select the Allow Immutability check box, then confirm the action in the dialog box.
  10. Click Save.
  11. Edit the backup plan that produced this error (code 2523) and specify for it the new backup destination created on steps 2-10.

In Backup for Windows

To do this, proceed as follows:

  1. In the application menu, select Edit Storage Accounts.
  2. Select the required AWS account, then click Edit.
  3. In the Bucket Name field of the Storage Account tab, select Create New Bucket.
  4. In the Create Bucket dialog box, specify the bucket name, then select the Enable Immutability** check box.

Note that you can only enable Immutability for new buckets. If you want to enable Immutability for an existing bucket, contact AWS Support

https://git.cloudberrylab.com/egor.m/doc-help-kb.git