BackBlaze B2 “Unauthorized” Error

Situation

Backup plan fails with the following error message:

2020-01-01 10:00:00,000 [CL] [2] ERROR - Generating chunks failed
CloudBerryLab.Base.Exceptions.Status401Exception
unauthorized

Cause

The BackBlaze (B2) storage account credentials are outdated or were deprecated through the B2 cloud storage management console (“App Keys” page).

Solution

Generate a new Application Key

  1. Open the B2 management console.
  2. Select App Keys.
  3. Click Add a New Application Key.

The Application Key must be set up to access all buckets and have access to both Read and Write operations. Do not specify any File name prefix.

Add the new key via MSP360 (CloudBerry) Backup GUI

  1. Open MSP360 (CloudBerry) Backup for Windows.
  2. In the application menu, select Edit Storage Accounts.
  3. In the list, select the Backblaze account that was causing the error, then click Edit.
  4. Specify the credentials for the new application key you have generated.
  5. Click OK

Add the new key via the Managed Backup Portal

  1. Open the Management Console.
  2. In the Storage menu, select Storage Accounts.

  1. Find the Backblaze account that was causing the error, then click the gear icon.
  2. Select Change Credentials.
  3. In the Change Credentials dialog box, specify the credentials for the new application key you have generated.

  1. Click Save.
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